Philivert

SPIP page blanche suite au passage à PHP 7.0.9

12 messages dans ce sujet

Bonjour,

Il y a une incompatibilité de SPIP avec la version PHP 7.0.9 qui se traduit par l'affichage d'une page vide avec une ligne d'erreur.

Le problème est connu et en cours de résolution par les dev

En attendant il se règle facilement en modifiant la ligne 246 du fichier "spip/ecrire/inc/pipelines.php"

Ainsi la fonction :
function f_queue(&$texte)
Devient :
function f_queue($texte)

testé ce matin sur 3 sites après le passage de http1 en php 7.0.9

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir

Merci Philivert , je viens d ' apporter cette correction à mon site sous spip.

Bonne Soirée

Partager ce message


Lien à poster
Partager sur d’autres sites

visiblement cette modification , me provoque d ' autres erreurs aussi bien sur la partie administration et site (après avoir vidé le cache spip et navigateur)

mon site est inexploitable

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, omega a dit :

visiblement cette modification , me provoque d ' autres erreurs aussi bien sur la partie administration et site (après avoir vidé le cache spip et navigateur)

mon site est inexploitable

Tu as quelle version de SPIP ? tu es sous PHP 7 ?

Avec SPIP 3.1.1 pas de pb après la modif.

Il y a 9 heures, plow a dit :

Aucun  problème sous wordpress :D

sauf les lenteurs sur l'administration ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Philivert , je viens de rétrograder mon site sous php 5.6 (7.xx --> 5.6) après avoir bien entendu vider le cache des répertoires local et tmp. ouf! ça remarche

je suis bien sous spip 3.1.1 mais avec Zcore/Bootstrap/Lesscss qui doivent poser problème lors d 'une compilation.

je vais attendre le correctif de l ' équipe de spip avant de rebasculer sous php7

merci pour ton attention.

si web4all pouvait nous notifier par mail (pour les personnes inscrites aux notifications) lors d 'un changement même mineur de version de php ce serait sympa ....

Bonne journée

Partager ce message


Lien à poster
Partager sur d’autres sites

oui mais il vaudrait mieux faire un test en local avant de le faire sur le site en prod, si c'est un pb avec Zcore/Bootstrap/Lesscss le correctif SPIP ne suffira pas forcément.

Bonne journée

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est bien ce pb qui est traqué par les dev, et pourquoi en php 7.0.9 et pas les autres versions ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, pour info je viens de tester sur mon serveur local avec PHP 7.0.10 et le problème a disparu.

Le pb est donc spécifique à la version 7.0.9 de PHP (j'ai testé toutes les versions de PHP 7 depuis sa sortie)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Philvert,

merci pour ce retour
il n 'y a plus qu ' à demander à l ' équipe de web4all de passer en Php 7.0.10

si un technicien est à notre écoute , est ce faisable dans les prochains jours ?

par avance merci

Partager ce message


Lien à poster
Partager sur d’autres sites
On 28/08/2016 at 10:27 AM, omega said:

Bonjour Philvert,

merci pour ce retour
il n 'y a plus qu ' à demander à l ' équipe de web4all de passer en Php 7.0.10

si un technicien est à notre écoute , est ce faisable dans les prochains jours ?

par avance merci

 

Fait hier : 

 

 updated from alt-php70-7.0.9-1.el6 to alt-php70-7.0.10-1.el6

 

Partager ce message


Lien à poster
Partager sur d’autres sites