Lafuente

Mods apache

21 messages dans ce sujet

Bonjour,

J'aimerais savoir si les mod apache :

  • mod_expires  (mise en cache navigateur)
  • mod_deflate   (compression gzip)
  • mod-headers    (contrôle des requêtes et réponses HTTP)

Sont disponibles sur les serveurs mutualisés.

Par avance merci.

Manu

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Merci pour cette réponse. Mon .htaccess comprend déjà ces modifications. Mais quand je passe le site sur https://www.gtmetrix.com ou google pagesight il est indiqué que ces mods ne sont pas installés.

donc il me semble que non, ce n'est pas en place par défaut :-(

Cordialement,

Manu

P.S. : mon site est http://www.megasquirt.fr

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Effectivement cela fonctionne. En fait j'avais pas fait attention au fait que ce sont des ressources externes qui génèrent les erreur de cache, à savoir ici :

http://maps.google.com/maps/api/js?region=FR (30 minutes)

C'est quand même grave que google te signale une erreur google non. PTDR....

Il va falloir que je vire tous les scripts google de ce thème car c'est pas la première erreur qu'ils génèrent, sans parler des ralentissements.

Merci pour tout.

Manu

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, tu ne pourras pas y  faire grand chose là-dessus.

Mais ne te prend pas trop la tête non plus sur toutes les précos, c'est très très rare d'atteindre le 100%.

Dans notre agence, un site bien optimisé obtient entre 80 et 90% en général

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci,

Franchement je n’essaie même pas de viser le double A, alors le 100% ! GTmetrix est bien, mais assez orienté commerce. Ainsi sur mon site j'utilise des CDN persos. Et GTmetrix me déclasse car pour lui je n'utilise pas de CDN. Donc conclusion : je n'utilise pas de CDN payants tels que GTmetrix le veux... MDR...

Par contre la lenteur d'affichage du site, surtout la homepage, est un réel problème... J'ai beau essayer de tout optimiser, limite il faudrait passer sur un VPS pour que ce pédale comme il faut, ou bien passer des jours sur le code pour virer le superflu... Trop long.

Merci pour tout et bonne continuation.

Manu

Modifié par Lafuente

Partager ce message


Lien à poster
Partager sur d’autres sites

Le fichier CSS qui fait + de 600Ko compressé, il est de toi ou c'est celui du thème ? Parce qu'il est énorme quand même...

Idem, +600Ko pour le fichier JS...

Tu peux aussi pas mal optimiser le poids de tes images, elles sont assez lourdes. Perso j'aime bien Caesium pour ça, il fonctionne plutôt bien.

Après il restera l'histoire du temps de serveur, mais déjà il faudrait éliminer les autres petits soucis avant :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Les fichiers CSS et JSD sont ceux du thème. Il y a surement plein de trucs à virer mais du coup on retombe sur l'aspect temps. Et comme c'est pas mon boulot j'ai plus trop de temps à consacrer à cela. D'où la solution de facilité => gros serveur...

Pour le poids des images, ce qui est problématique aujourd'hui c'est le responsive. Comme les diagonales d'écran deviennent de plus en plus grandes et la résolution également, il faut trouver un point moyen pour satisfaire tout le monde.

Et étant une petite structure, je n'ai pas forcement les moyens de payer un dev special :-(

Mais merci pour le temps que tu as passé à regarder cela !

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour les images, essaye Caesium, c'est ce qu'on utilise ici et franchement sauf cas particuliers tu ne vois quasiment pas la différence :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok je vais essayer. Mais c'est plus efficace que totoshop avec sa fonction d'optimisation pour le WEB ?

Effectivement... Ça fonctionne dans certains cas, dans d'autres non.

Par exemple les images du slider pèsent actuellement 199k, après passage dans Caesium elle pèsent 326k.

Pour le megamenu avant 224ko, après 119ko...

Merci ;-)

Modifié par Lafuente

Partager ce message


Lien à poster
Partager sur d’autres sites

Y'a des trucs bizarres tout de même, si je regarde l'image

"http://www.megasquirt.fr/modules/tmmegamenu/images/bb7d5ff1903268d48eb4759b7021ef3b8a5ab7a1_calculateur-pnp.png"

Elle pèse 87,47ko alors que sur mon PC elle pèse 39,5ko. Et elle a la même définition...

Vide le cache Manu, tu le sais....

Mais du coup je perds le détourage et la transparence.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Truc débile, mais enfin... En uploadant les images au poid correct directement par FTP avec le même nom que les images uploadés par l'interface de prestashop ca fonctionne. C'est à dire que si mon image pèse 17ko sur mon PC, je crée, par exemple, le menu qui va l'utiliser et j'upload l'image de 17ko par l'interface de prestashop. Et là, paf l'image fait 87ko :o avec un nom comme on les aiment bien, genre xtefhouzlejtfrzoaiergtjeropgte.png

Là je remplace cette image par l'originale de 17ko par ftp en conservant le nom assigné par prestashop, et hop j'ai la bonne image avec le bon poids... Pas pratique mais bon maintenant je sais comment faire... Du coup hop, A(97%) à pageSpeed Score, et cela juste en optimisant 10 images...

Bon, quand j'aurais le temps je me colle au code...

Merci pour les infos.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Je viens de comprendre un problème de prestashop et j'espère que cela pourra profiter à la communauté. A propos du problème du poids des images. Prestashop procède à une génération automatique de différentes tailles d'images d'un produit afin d'avoir plusieurs variantes en fonction de l'endroit où s'affiche l'image.

Ainsi, lorsque vous uploadez une image pour un produit, il va se créer plusieurs "sous-images". Prestashop est alors censé optimiser le poids de cette image. Cela fonctionne très bien, TANT QUE VOTRE IMAGE ORIGINALE EST CARRÉE. Si votre image n'est pas carré, alors le poids des images créées peut potentiellement être plus lourd que l'image originale, même si la taille de l'image générée est plus petite. C'est mon cas pour plusieurs image de ma home-page.

Je les ai repris à la main, et le poids de ma home-page est passé de 6,7Mo à 1,27Mo !!! Je ne vous explique pas le gain de temps de chargement ;-) Et je n'ai pas encore tout fini, j'ai juste traité l'urgence !

Cordialement,

Manu

https://www.megasquirt.fr

Modifié par Lafuente

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

En faire un retour à prestashop ne serait pas mieux ?

Cdlt

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 17 minutes, Timelord a dit :

Bonjour,

En faire un retour à prestashop ne serait pas mieux ?

Cdlt

Bruno

Bonjour,

Si les codeurs Prestashop écoutaient les remarques qui leurs sont formulées, ce se saurait. Fait une recherche à ce niveau sur le net et tu verras que des erreurs importantes signalées couramment depuis 2009 ne sont toujours pas traitées.

Si tu veux perdre du temps, tu peux toujours essayer ;-)

++

Manu

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Hum ca doit fonctionner que quand tu es un utilisateur payant alors !

C'est n'importenawak !

Cdlt

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites

Je te confirme, tu vas perdre ton temps à faire un retour à Prestashop.

On leur remonte de temps en temps de bug / problème au niveau du code de presta en lui-même, on a rarement des réponses...

Partager ce message


Lien à poster
Partager sur d’autres sites

Clair, regardez le bug de l'arrondi qui est signalé depuis la v1.2 et toujours présent dans la 1.7...

C'est juste un bug sur le calcul du prix final et qui impacte directement la facturation, rien de grave... En plus les solutions existent, il faut juste tout faire à la main...

Donc puisqu'ils n'ont pas le temps de prendre en compte les bugs, pourquoi perdre du temps à leur signaler...

Prestashop est un très bon e-commerce ! Mais il ne faut pas avoir peur de mettre les mains dans le cambouis.

Et puis il y a aussi une logique commerciale tout a fait compréhensible. Rien n'est gratuit aujourd'hui et il faut bien que Presta, ainsi que les devs qui bossent autour, puisse gagner de l'argent pour continuer à vivre. C'est fini l'époque d'OS Commerce et du développement dans son garage. L'E-commerce vit.

il y a 16 minutes, Timelord a dit :

Hum ca doit fonctionner que quand tu es un utilisateur payant alors !

:o Jamais vu une telle personne... Ça existe ?

En général les personnes que je connais pour avoir payé leurs boutiques sont passées par des agence de COM comme Kerweb, iLoop ou autres. Et non directement par Prestashop. Et l’intérêt d'une agence de COM est d'avoir la bonne personne en interne (à mon avis).

Modifié par Lafuente

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Timelord a dit :

En faire un retour à prestashop ne serait pas mieux ?

Enfin pour finir cet aparté, ce n'est peut-être pas un bug, mais une contrainte technique. Dans ce cas là on appelle cela un Pré-requis...

Voir, c'est peut-être expliqué quelque part dans la doc officielle, je ne l'ai pas lue...

Le but inital de mon post était avant tout :

Le 10/12/2016 at 21:26, Lafuente a dit :

cela pourra profiter à la communauté.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Globalement ce que tu dis c'est que tu mets la main "à la patte" et que tu partages ton travail car tu es un gentil :P

C'est p'être le moment que je me penche plus sur le produit ;) car je vais en avoir besoin pour une amie.

Cdlt

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites