• 0
alexbesnier

[Résolu] Entrée DNS sur un sous domaine

Question

Bonjour,

Depuis un moment maintenant j'ai ajouté une entrée TXT à la zone DNS de mon nom de domaine. Mais si je test les DNS de mon nom de domaine via des site tiers (du genre http://manytools.org/network/query-dns-records-online/) je ne vois pas ressortir mon entrée TXT, je vois seulement celle par défaut de web4all : abws.fr. 7200 IN TXT "v=spf1 a mx ptr include:mx.w4a.fr ?all"

Dans ma zone DNS j'ai ajouté la ligne suivante :
- Champ : m (=> correspondant au nom du sous domaine que je souhaite)
- Type : TXT
- Cible : protonmail-verification=...

De par ailleurs mon sous domaine "m" est bien créé sur la page Synthèse des domaines du manager (sans web ni mail).

Au début je pensais à une propagation lente, mais au bout de plus d'une semaine, c'est pas normal.

Autre point, comme mon nom domaine n'est pas fourni par web4all mais par OVH, j'ai aussi suspecté un problème de "passerelle", mais si je fait un ping sur une entrée IN A que j'ai ajouté depuis longtemps à ma zone, l'adresse IP renvoyé est bien celle qui est sauvegardée. J'en conclu donc que ma zone DNS marche bien même pour les entrées custom.

Au final je ne comprends pas ce qui ne va pas, je dois faire une mauvaise configuration mais là je sèche.

Si quelqu'un à une idée je suis preneur. Merci

 

Modifié par alexbesnier

Partager ce message


Lien à poster
Partager sur d’autres sites

16 réponses à cette question

  • 0

Bonjour,

ça a mis un peu de temps, mais on a réussi à réglé le problème. La cause du problème n'est pas totalement connue, mais ils supposent que c'est un CNAME sur le champ "m" qui pouvait poser problème.

Du coup on a supprimé toutes les entrées, puis remis mon entrée TXT.

@Timelord C'était justement mon soucis ^^ De l'extérieur on ne voyait pas ce champ TXT et donc protonmail ne pouvait pas valider mon nom de domaine. Si j'ai bien compris ma zone DNS se s’exécutait pas jusqu'à la fin à cause d'une erreur, et donc mes champs TXT qui s'ajoutaient à la fin n'étaient pas traités.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir,

Il y a 3 heures, alexbesnier a dit :

mon sous domaine "m" est bien créé sur la page Synthèse des domaines du manager (sans web ni mail).

S'il n'y a pas de web, c'est normal que ton sous domaine ne fonctionne pas...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Je ne pensais pas que ce soit nécessaire de créer le web pour faire fonctionner les DNS. Je ne prévois pas d'utilisé ce sous domaine pour une publication web, juste pour mes mails.

J'ai fait la modif en tout cas, je vais voir ce que ça donne.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

C'est quoi votre nom de domaine ?

Cdlt

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Pour moi  l'alias "m" pour le nom de domaine "abws.fr" fonctionne même s'il renvoie nul par en terme de contenu !

Vous voulez vous en servir pour vos mails ?

Cordialement,

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour Bruno,

Oui le sous-domaine fonctionne correctement, mais je truc c'est que j'ai besoin d'avoir une entrée TXT particulière dessus. J'ai un compte chez protonmail, et pour s'assurer que je suis bien propriétaire du nom de domaine il vérifie qu'une clé est bien présente sur le DNS. Jusqu'à maintenant je n'ai donc pas réussi à activer mon domaine m.abws.fr sur protonmail pour pouvoir envoyer des mails en @m.abws.fr plutôt qu'en @protonmail.com.

Tous ce qui est web/mail fourni par web4all ne m'intéresse pas pour ce sous domaine.

Sinon j'ai ajouté une entrée TXT au domaine principal, abws.fr, mais au final c'est pareil si je test le DNS y'a que l'entrée web4all qui apparait.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Vu que le problème n'est toujours pas résolu, vous pensez qu'il faudrait que j'ouvre un ticket via le manager pour qu'une personne du staff regarde le soucis ? Ou bien ils passent souvent sur le forum et ça ne ferait que doublon ?

Mercii

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a une heure, alexbesnier a dit :

Vu que le problème n'est toujours pas résolu, vous pensez qu'il faudrait que j'ouvre un ticket via le manager pour qu'une personne du staff regarde le soucis ? Ou bien ils passent souvent sur le forum et ça ne ferait que doublon ?

Ils passent mais le support "officiel" se fait uniquement via le manager. Donc oui au ticket :)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Pourtant le champs est bien présent :

 dig txt  m.abws.fr

; <<>> DiG 9.9.4-RedHat-9.9.4-29.el7_2.4 <<>> txt m.abws.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18847
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;m.abws.fr.                     IN      TXT

;; ANSWER SECTION:
m.abws.fr.              7096    IN      CNAME   abws.fr.
abws.fr.                7164    IN      TXT     "v=spf1 a mx ptr include:mx.w4a.fr ?all"

;; AUTHORITY SECTION:
abws.fr.                172688  IN      NS      ns1.web4all.fr.
abws.fr.                172688  IN      NS      ns2.web4all.fr.

;; ADDITIONAL SECTION:
ns1.web4all.fr.         163394  IN      A       185.49.20.10
ns2.web4all.fr.         163394  IN      A       91.220.248.154

Ce qui n'existe pas visiblement c'est le : mx.w4a.fr ! Aucune résolution pour cela !

Le mieux comme le dit simon est de faire un ticket ! Je pense que vos informations TXT ne sont pas totalement bonnes.

Cordialement,

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Par contre, vous parlez que protonmail contrôle une "clé" dans un champs TXT de votre NDD !

Je ne vois rien de la sorte !

Bon courage.

Cordialement,

Bruno

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Et si de l’extérieur je le voyais : cf la ligne :

abws.fr.                7164    IN      TXT     "v=spf1 a mx ptr include:mx.w4a.fr ?all"

Cdlt

Bruno

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Non cette ligne est là par défaut, elle est créé automatiquement par web4all à la création du domaine (pour la gestion des mails). Celle qu'on ne voyait pas était une entrée avec comme valeur quelque chose du type "protonmail-verification=Cle".

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Y'avait pas cette info dans votre demande ? pas grave, le principal c'est que cela soit résolu.

Cordialement,

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites